1
0
Fork 0
puter/profiles/desktop/firefox.nix
2025-05-11 22:49:04 +02:00

25 lines
494 B
Nix

{
config,
lib,
pkgs,
...
}:
let
cfg = config.profiles.desktop;
in
{
config = lib.mkIf cfg.enable {
programs.firefox = {
enable = true;
package = pkgs.librewolf;
preferences = {
"webgl.disabled" = false;
"privacy.resistFingerprinting" = false;
"middlemouse.paste" = false;
"general.autoScroll" = true;
"privacy.clearOnShutdown.history" = false;
"privacy.clearOnShutdown.downloads" = false;
};
};
};
}