1
0
Fork 0
puter/profiles/emulation/default.nix
2025-05-11 22:49:04 +02:00

18 lines
359 B
Nix

{ config, lib, ... }:
let
cfg = config.profiles.emulation;
in
{
options.profiles.emulation = {
enable = lib.mkEnableOption "emulation";
};
config = lib.mkIf cfg.enable {
assertions = [
{
assertion = config.profiles.desktop.enable;
message = "The emulation profile depends on the desktop profile.";
}
];
};
}